2

I have built stellar-core and horizon instances from source on Ubuntu 18.04 LTS.

I managed to make them work for the test-net, yet now, whilst trying to configure stellar-core.cfg for the public network, I am unable to connect to peers.

I have tried multiple .cfg specifications, but always end up with issues related to the Overlay component of stellar-core.

By using the following .cfg file:

https://raw.githubusercontent.com/stellar/docker-stellar-core-horizon/master/pubnet/core/etc/stellar-core.cfg

I get the following log output:

[Overlay WARNING] 2018-06-21T13:34:44.778 GCZGU [Overlay ERROR] TCPPeer::drop shutdown socket failed: Transport endpoint is not connected [TCPPeer.cpp:195]

What could be the issue here? I looked int othe TCPPeer.cpp file, and that was not as well documented as I had expected since line 195 only referred to printing an error message without explaining where the error was generated.

Edit With an alternative stellar-core.cfg I ended up with the following log:

2018-06-21T12:11:35.429 GDMPG [Overlay TRACE] OverlayManagerImpl tick [OverlayManagerImpl.cpp:288]

...

What am I doing wrong?

Edit 1 After letting stellar-core and horizon run for a while with the first configuration (prior to Edit, in other words the Container solution), eventually bucket entries where added. Yet, after a while horizon asked me to re-create the horizon PSQL database since I had not done this prior to evolving to the public network.

After re-creating the PSQL database for Horizon, and re-initializing it with horizon db init, the stellar-core database with stellar-core --newdb I am unable to fetch the History buckets from the Stellar core history bucket repository available at:

http://history.stellar.org/prd/core-live/core_live_001/bucket/b7/2b/c2/bucket-b72bc26d469a3f5079510767e2ea4773e02da574dec72e2f32f5828b79e0af40.xdr.gz

I am not sure why this happens, since it appeared to be just fine yesterday. As is noticeable, the URL gives a 404 error. Anyone got some advice on defining the bucket directories correctly? Or are the history repositories down during certain time periods?

bumped to the homepage by Community 12 hours ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

0

Getting the same issue with the testnet second day in row. But after a 30 min of sync up attempts, I was able to connect to the testnet. I think it's something wrong with the network on the validators side.

  • I think the issue arises because Stellar-core has to sync, as indicated by Horizon. Right now, I am getting several [Bucket INFO] Bucket-apply: committed xxxxx entries, after I let both instances of Horizon and Stellar-core run for a few minutes. It has been like that for a while now, so I am leaving it at that for a while to see what happens. – M.Bradascio Jun 21 '18 at 13:21
0

NOTE: Horizon is just like a plugin of Core, which should not affect the behaviour of Core. You may ignore the Horizon part for the moment, as your issue is with Core.


It seems to me that you might have kept the testnet history files of Core, which could mislead Core which was trying to sync with public-network.

As you first had the testnet up-running, it was holding and generating new testnet data (DB records & history files). Later, you tried to change it to the public network, but those old data were not deleted, which could be problematic.


My suggestion would be:

First, stop your stellar-core application.

Second, with your new config for public network, do stellar-core --newdb to reintialize the DB part.

Then, delete everything related to the testnet history files /opt/stellar/history-cache/{0} {1}.

Finally, do stellar-core --newhist cache, to prepare history files for public network (newhist "cache", as I read that you use [HISTORY.cache]), and you can start stellar-core application.

p.s. For public network, it might be better to choose validators from here. At the time of post, it seems those "Stronghold" nodes might be problematic, and you may try others.


As I have heard of, many people indicated that it takes "some" time to start catching-up to the gigantic test-net / public live-net. Such time varies from minutes to ten hours. So...maybe do all the re-intialization steps, and then sit back and wait, for up to 10 hours.

If it persists, please provide more detailed steps of how you did it...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.