1

StellarExpert says that related domain for my asset was not found.

I published toml file as https://capitalcryptoworld.io/.well-known/stellar.toml, where capitalcryptoworld.io is my domain name.

Why my asset is not verified?

4

Here is a step-by-step process of the basic asset verification:

  1. Set home_domain field for your asset issuing account. Clients can look up a stellar.toml from this domain.
    • This should be in the format of a fully qualified domain name such as example.com, anchor.example.com etc.
    • DO NOT include scheme (i.e. http or https) and trailing relative path: https://example.com or example.com/tokens won't work.
    • Find more details and code samples here.
  2. Create stellar.toml following directions from the official Stellar guide.
    • Do not forget to add the [[CURRENCIES]] for each of your assets.
    • Provide a short meaningful asset description (parameters name, desc and conditions) to tell your users what it's all about (optional).
  3. Publish your stellar.toml file, clients will search it at the following location: https://your_domain.com/.well-known/stellar.toml.
    • Make sure that CORS (cross-origin resource sharing) is enabled.
    • Also check the content type, should be content-type: text/plain; charset=utf-8. Some clients/browsers may not handle it correctly if content is transferred as application/octet-stream, not text/plain as expected.
  • [[CURRENCIES]] code="CCC" issuer="GDEH2IUXOBIJXMX5KTQSKYB4E2DGQCT34LCJM3TG7JQFJO6FTONQHTUC" display_decimals=4 name="CCC" desc="1 CCC token represent 1 cat in the world" conditions="There will only ever be 1,000,000,000 CCC tokens in existence." image="capitalcryptoworld.io/images/logo.png" this is my toml file tell me which thing should i include in it – Fahad Aug 7 '18 at 14:00
  • Field home_domain is not set for the issuing account GDEH2IUXOBIJXMX5KTQSKYB4E2DGQCT34LCJM3TG7JQFJO6FTONQHTUC. – Orbit Lens Aug 7 '18 at 14:44
  • how i set the home domain? – Fahad Aug 7 '18 at 14:47
  • See paragraph 1. "Find more details and code samples here." – Orbit Lens Aug 7 '18 at 14:53
  • i follow the step but it not verified the asset – Fahad Aug 7 '18 at 15:03
2

OrbitLens does a good walkthrough of the steps needed.

Ultimately, your asset isn't set as verified because you haven't added a homedomain to the issuing account.

A stellar.toml isn't any good if the network doesn't know how to find it.

0

You also have to enable CORS. Don't forget that step it took me days to figure it out. Even though the guidelines says to do it, it's easily overlooked and if you're not familiar, very confusing.

https://stellarport.io/assets/alphanum4/VOID/GB4UBYTLHNDDIP75CZRWE2LTM3M7UCWHVPEM4FPUXGUWMJFSWTGBEZDO

https://stellar.expert/explorer/public/asset/VOID-GB4UBYTLHNDDIP75CZRWE2LTM3M7UCWHVPEM4FPUXGUWMJFSWTGBEZDO

Here is the asset I created please feel free to ask me any questions if you have them.

  • That is step 3 of OrbitLens' answer. – Chenmunka Feb 1 at 18:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.