Anyone know what this means or how to fix it?

I ran the command npm install --save stellar-sdk and got this

LINK : fatal error LNK1181: cannot open input file 'C:\OpenSSL-Win64\lib\libe
ay32.lib' [D:\Stellar\node_modules\ed25519\build\ed25519.vcxp
roj]

Any help/explanation is appreciated. Thank you.

EDIT: IF anyone else encountered this issue, you can just ignore it and it wtill works fine.

  • Do you have OpenSSL installed? – Synesso Aug 10 at 10:59
  • I was searching for an answer to this and tried. I downloaded 3 different Open SSL versions from here and put them in the path specified but they only have a libeay32.dll and not a libeay32.lib . I also tried just changing the .dll to a .lib but still got an error. – John Murphy Aug 10 at 11:41
  • 2
    It's not a critical error, just ignore it. ed25519 package offers binaries for the fast ED25519 signing, but it's an optional dependency. Bundled crypto-js version works just fine. – Orbit Lens Aug 10 at 12:26
  • I get that error too.. like what @OrbitLens said, you can ignore it and the sdk will work fine. – tracy Aug 11 at 11:37

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.