3

I keep getting this error after the initial download of ledger files has caught up. After this error, it attempts to re-download the ledger files.

2018-08-27T13:04:12.199 GDU4N [History ERROR] Catchup material failed verification - unsupported ledger version, propagating failure [VerifyLedgerChainWork.cpp:252]
2018-08-27T13:04:12.199 GDU4N [Ledger ERROR] Error catching up: Connection timed out [LedgerManagerImpl.cpp:536]
2018-08-27T13:04:12.199 GDU4N [Ledger ERROR] Catchup will restart at next close. [LedgerManagerImpl.cpp:537]
2018-08-27T13:04:12.200 GDU4N [Ledger INFO] Changing state LM_CATCHING_UP_STATE -> LM_BOOTING_STATE
2018-08-27T13:04:12.203 GDU4N [Work WARNING] WorkManager got FAILURE_FATAL from catchup
2018-08-27T13:04:38.331 GDU4N [Overlay WARNING] idle timeout

I'm using the SDF packages.

I tried to docker pull stellar/quickstart:testing like this solution, but I'm still getting the same error.

3

As jbrejcha mentioned, it looks like you are trying to connect to Tesnet using version 9 of the protocol.

The official unstable repository contains the Release Candidates, these are marked -rc.

It is worth mentioning that the SDF recommends you only use these packages in testing and stick to the stable repository for your production environments.

Follow these instructions to add the SDF unstable repository, you will then be able to install a V10 release candidate:

apt-get update && apt-get install stellar-core=10.0.0rc2-16

Once version 10.0.0 is officially released the package will be available in the stable repository.

  • Thanks Tom. I updated stellar-core to v10 the sync is now working. – Vincent Wardhana Aug 30 '18 at 3:10
0

It seems you are still running version 9 of stellar-core. When opening http://localhost:11626/info you should see "build" : "v10.0.0rc2", in the upper part of the screen.

If not, you need to specify the "testing" option when running docker, such as: docker run --rm -d -p "8000:8000" -p "5432:5432" -p "11626:11626" -p "11625:11625" -v "/Users/myaccount/stellar:/opt/stellar" --name stellar stellar/quickstart:testing --testnet

Otherwise you would still be running the original stellar/quickstart package.

  • Yes thanks for respond. As you said its because mine still v9. I updated to v10 and now its working – Vincent Wardhana Aug 30 '18 at 3:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.