1

I ran a basic private network with the line COMMANDS=["upgrades?mode=set&upgradetime=1970-01-01T00:00:00Z&basefee=0&basereserve=0"] inside of my stellar-core.cfg file on all of my nodes (5 of them), so I'm expecting the network to treat all transactions with 0 baseFee and 0 baseReserve. However, when I run stellar-core --c info, I can see that baseFee=100 and baseReserve=100000000 under ledger, which I'm assuming is the default amount. So either that the command I ran didn't get applied correctly or there is a difference between the ledger's baseFee and baseReserve. What's going on?

  • 1
    This may be of interest - I’m not sure if it is still the case but you can try it with 1 to see if it works github.com/stellar/stellar-core/issues/1594 – Paul Oct 4 '18 at 0:46
  • Well the OP of that issue says he's getting a [default INFO] could not parse basereserve: '0' Failed to parse 'basereserve' argument error which I'm not getting, but who knows... – B.Li Oct 4 '18 at 17:02
0

@Paul was right in the sense that you can't set the base reserve to 0. change it to 1 and it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.