i have some problem with a test-net horizon that is not syncing. I'm using the quickstart docker image and i see core is fully synced (state: "Synced!").

On horizon i see that history.latest_ledger and core_latest_ledger: 552182 are in sync and on the latest values corresponding to the pub-testnet. On the log i see, that horizon is ingesting the newest ledgers.

But on horizon the history.elder_ledger is somehow on 180735. Of course i can't see any new transactions in the horizon db.

Can someone explain please, what those 2 values mean? history.latest_ledger and history.elder_ledger.

Also, how can i get horizon to sync everything? I tried all different ways from https://www.stellar.org/developers/software/known-issues.html but nothing helps.

Also tried CATCHUP_COMPLETE=true with no luck.

  • sorry i was wrong. New transaction are ingested correctly but horizon does not ingest the missing once. – Udo Polder Nov 6 at 11:43
up vote 1 down vote accepted

history.latest_ledger is the most recent ledger ingested by horizon from stellar core.

history.elder_ledger is the oldest ledger ingested by horizon from stellar core.

When horizon is ingesting new ledgers from stellar core, history.latest_ledger and core_latest_ledger are usually equal, or differ by a value of 1.

To have horizon ingest the complete history, you need to add the following configurations

  • CATCHUP_COMPLETE=true on stellar core (I believe you have done this)
  • HISTORY_RETENTION_COUNT=0 horizon

Note that you will need to stop the running horizon service, empty the horizon database and restart the service for this to take effect.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.