0

I am running a private network with 3 nodes. DUe to some reason I have to stop 3rd node and when I am restarting getting following status again and again:

"status" : [ "Catching up: downloading transactions files 3526/9639 (36%)" ]

"status" : [ "Catching up: applying checkpoint 1/9639 (0%)" ]

"status" : [ "Catching up: Waiting for trigger ledger: 616950/616961, ETA: 55s" ]

"status" : [ "Catching up: Retrying in 7 sec: apply-ledger-chain" ]

"status" : [ "Catching up: Retrying in 27 sec: apply-ledger-chain" ]

"status" : [ "Catching up: Waiting for trigger ledger: 616986/617025, ETA: 195s" ]

Note:The same issue I am getting when I am trying to add new node to this existing network.

Update - When I set the CATCHUP_COMPLETE flag as false, the node is coming to sync status. In first two nodes, this flag is true and still they are in sync.

When this flag is set as true, the node is not syncing. WHat can be the issue if I set up the CATCHUP_COMPLETE flag as false?

And if I set CATCHUP_COMPLETE flag as true then how to bring the node to sync.

  • If CATCHUP_COMPLETE = false, it will only synchronize the last CATCHUP_RECENT ledgers and dont care about older ones. A complete catchup is performed using the history archive, maybe yours is either broken or not accessable, double check your [HISTORY] configuration. – sui Feb 14 at 16:07
1

Go straight with an example: suppose now, current ledger is #567

CATCHUP_COMPLETE=true -> The node gets data since the very beginning of your private chain, i.e. ledger #1, up to #567

CATCHUP_COMPLETE=false -> The node gets only recent data (e.g. & CATCHUP_RECENT=64 -> The node gets the data only from ledger #503 to #567)


Now you are adding a 3rd node. It works with CATCHUP_COMPLETE=false, but not CATCHUP_COMPLETE=true.

A possibility is that your first two nodes somehow do not possess the required information between ledger #1 to #567, making your 3rd node endlessly asking for some non-existing data from 1st & 2nd node.

Please also confirm if your 1st & 2nd node have CATCHUP_COMPLETE with true or false.

  • Thanks @cesarm I got a clarity on CATCHUP_COMPLETE , My first two nodes are running well with the flag set as true. Thats why I am in doubt that 1st 2 nodes might miss some data. And lets say they miss data, then how do I make sure the data is not missed during setup? – sweta Feb 15 at 12:14
  • not sure if there is any way to ensure no missing data, as i think blockchain should be extensively duplicated with multiple full nodes (i.e. nodes with all data from the 1st block/ledger) – cesarm Feb 16 at 16:26
  • not sure with any way to ensure no missing data, as on a blockchain system it should be assumed that there are always some full nodes (nodes with all data since the very beginning of the chain) – cesarm Feb 16 at 16:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.