0

I have setup a stellar core in local. However when I start the core, it binds to local host. How can I bind it to ip address instead?

1

Stellar-core has two interfaces, one is the public p2p port and the other is a http interface. The (admin/monitoring/info-) http interface is not supposed to be exposed to the public, so you might want to set some according firewall rules or set up a proxy before doing that.

However the configuration parameter to bind to any ipv4 address is: PUBLIC_HTTP_PORT=true

  • but this is not recommended right? – sweta Feb 22 at 12:36
  • Not as long as you can't ensure that anyone else can access it. – sui Feb 22 at 12:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.