I build a docker image from the v0.17.0 tag of docker-stellar-core-horizon.

Then, I created a local standalone network from that image:

docker run --rm -d -p "8000:8000" -p "11626:11626" \
  -p "5433:5432" --name stellar synesso/stellar:v0.17.0 --standalone

The instance root document is:

curl -s http://localhost:8000/ | jq '.|del(._links)'

  "horizon_version": "v0.17.0",
  "core_version": "v10.2.0",
  "history_latest_ledger": 1783,
  "history_elder_ledger": 2,
  "core_latest_ledger": 1783,
  "network_passphrase": "Standalone Network ; February 2017",
  "current_protocol_version": 10,
  "core_supported_protocol_version": 10

I create and fund a few accounts, and make a non-native payment.

$ curl -s "http://localhost:8000/accounts/GBZX...MADI/payments" | \
  jq '._embedded.records[3] | del(._links)'

  "id": "25769807878",
  "paging_token": "25769807878",
  "transaction_successful": true,
  "type": "path_payment",
  "type_i": 2,
  "created_at": "2019-02-27T04:40:11Z",
  "transaction_hash": "c5e29c7d19c8af4fa932e6bd3214397a6f20041bc0234dacaac66bf155c02ae9",
  "asset_type": "credit_alphanum12",
  "asset_code": "Chinchilla",
  "amount": "0.0000001",
  "path": [],
  "source_amount": "0.0000001",
  "source_max": "0.0000001",
  "source_asset_type": "credit_alphanum12",
  "source_asset_code": "Chinchilla",

In the Horizon DB, the history_assets table contains the asset:


But the asset_stats table contains nothing.

Because the query to load assets joins these two tables (I might be looking in the wrong place), the call to /assets returns a 404.

curl "http://localhost:8000/assets"
  "type": "https://stellar.org/horizon-errors/not_found",
  "title": "Resource Missing",
  "status": 404,
  "detail": "The resource at the url requested was not found.  This is usually occurs for one of two reasons:  The url requested is not valid, or no data in our database could be found with the parameters provided."

Most likely, I am missing some important config or setup step. But I can't figure out what it is.

  • any traces of log from Horizon? and, what is returned from curl "http://localhost:8000"?
    – cesarm
    Commented Feb 27, 2019 at 6:52
  • There's no stdout emitting from the container, so I'll have to chase the logs down. In the meantime, I've updated the question with the content of the root document.
    – Synesso
    Commented Feb 27, 2019 at 7:09
  • In the horizon config there's a property export DISABLE_ASSET_STATS="true" and log level is set to INFO.
    – Synesso
    Commented Feb 27, 2019 at 7:12
  • @cesarm I was unable to find any logs in the container. I attached to it and re-ran my tests, but no stdout/err was presented.
    – Synesso
    Commented Feb 27, 2019 at 7:20
  • I added -e LOG_LEVEL="debug" -e DISABLE_ASSET_STATS="false" to my docker run command, but it didn't have an effect. I will try modifying the config directly.
    – Synesso
    Commented Feb 27, 2019 at 7:24

1 Answer 1


Asset stats are disabled by default, you can enable them with ENABLE_ASSET_STATS=true.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.