2

As the title suggests. I am trying to send XLM from my Ledger Blue via https://www.stellar.org/account-viewer/#!/dashboard . I have done this numerous times in the past and not had an issue. My firmware and software are up to date on the ledger blue. I am using Chrome. I verified the memo and address I am sending it to and I get to the screen and it says "Check the transaction using your Ledger device.

Submitting transaction to the network..." with the picture of the rocket and I click submit on the Ledger blue and then nothing else happens?

I have also had the following error:

{
  type: "https://stellar.org/horizon-errors/transaction_failed",
  title: "Transaction Failed",
  status: 400,
  detail:
    "The transaction failed when submitted to the stellar network. The `extras.result_codes` field on this response contains further details. Descriptions of each code can be found at: https://www.stellar.org/developers/learn/concepts/list-of-operations.html",
  extras: {
    envelope_xdr:
      "AAAAAN7JMvKZafqQZzRd41XrftTxZDFnFxfquZrzVf+S7c/2AAAAZAD/sl0AAAABAAAAAQAAAAAAAAAAAAAAAFy9yu0AAAACAAAAAD7iElEAAAABAAAAAAAAAAEAAAAADq+QhtWseqhtnwRIFyZRdLMOVtIqzkujfzUQ22rwZuEAAAAAAAAB0aixiYAAAAAAAAAAAZLtz/YAAABA+qSn3Z7nCjEs3qL/512XdzwHSeesRZrmYg5IWVkRfP39D07K8f4QeNnSREDpjXxT+cRUElMM6CiyrBgX1cm/AA==",
    result_codes: { transaction: "tx_bad_auth" },
    result_xdr: "AAAAAAAAAGT////6AAAAAA=="
  }
}

I was told the error (when I get it 50/50) was a "signature issue". I floated this on Reddit and tried all of the suggestions there: Swapped out USB connector cable, complete recovery mode/reboot of Ledgerblue, reinstall firmware/software, empty cache on Chrome, tried using Opera. I am using a MAC with the latest OS.

Thanks very much for any assistance you can provide!

  • 1
    Do you see any errors in the console? – Carl Vitullo Apr 23 at 14:28
  • I also tried sending this to other addresses as well and it has not worked. Just in case that is a course of action someone would suggest. Thanks again for any help, I have been actively working this issue for 36hrs now. I emailed Ledgersupport yesterday but know they are busy as well. Thanks again. – Darryl Apr 23 at 15:33
  • When I do get the error above, I have noticed that the first time I hit to confirm the transaction on my ledger blue, the screen blips, then I have to hit the confirm button again to submit the transaction. This then gives me the error page I have provided about signatures. I have been using the ledger to move btc and eth back with no issues so this leads me to believe it is a Stellar specific issue? I also have not heard back from LEdger support and it has been a few days now. Maybe that is normal? Thanks again for the assistance. – Darryl Apr 25 at 5:04
0

I'm getting the same problem trying to send XLM via the Ledger Blue. I'm also using Chrome on macos. I tried resetting the Ledger Blue using the recovery seed but same problem. It has latest firmware and apps are latest version.

I see the rocket picture and "submitting transaction to network..." but it just hangs there. I didn't get the error message you sometimes see, but the Ledger Blue does blip and ask you to confirm again about 50/50 of the time.

I just restored my seed to my Ledger Nano S to see if it's a Ledger Blue issue, but that has the same issue too.

1

It does look like you have a bad signature. You can inspect the transaction XDR that you submitted in the Stellar laboratory: your transaction shows a red cross next to the signature, indicating it is not correct (for comparison, here's an example of one with a valid signature).

Now why is the signature wrong? That's the question. Some possibilities: the hardware may have a corrupt/incorrect secret key. Or it's not being passed to the site correctly. Or there's a bug in the site. Or you need additional signers for the operation in question. One way to narrow this down would be by using a different wallet to submit.

0

Per the docs for possible errors

BAD_AUTH: Too few valid signatures / wrong network.

This might be an issue with the Ledger Blue, but I see a commit from January that purports to fix connection issues with hardware ledger devices.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.