0

Hi I was doing some experiment (especially after the news of stellar network going down) in my simple 2 nodes private network and got some confusion. Here are the steps I follow:

  1. Configured network with 2 nodes, both of them are validators and are included into each others quorum sets with theshold of 50% like this:
[QUORUM_SET]
THRESHOLD_PERCENT=50
VALIDATORS=[
    "$node01",
    "$node02"
]
  1. I stopped the 1st node for some time - the SCP still works with a 2nd node only, since the THRESHOLD_PERCENT was 50 (1 out of 2)
  2. Restarted the 1st node - it started catching up with the 2nd node.
  3. But what I am seeing is they both are running on different ledger state like the 1st node is trailing 2nd node. I was expecting that after some time they both should work on same slot but 1st one is always lagging behind.

What am I missing in concepts ?

EDIT: 1st node is always in "state" : "Catching up","status" : [ "Catching up: Waiting: catchup" ] state. Also none of transaction works on 1st node.

  • Check your logs. What's your history config? Can 1st one acces the history archive of the 2nd one? – sui May 27 at 10:58
  • Hey @sui sorry for the late reply. And thanks for the suggestion. that is what I doing wrong. I fixed the history get of node 1 to point to node2's. – Vishwas Bhushan May 31 at 5:16
0

So fixed this problem. My node1's get in history was not pointing to the node2's archive path. After setting them properly it worked.

Node1's history configuration

[HISTORY.local]
get="cp /tmp/stellar-core/node02/history/vs/{0} {1}"
put="cp {0} /tmp/stellar-core/node01/history/vs/{1}"
mkdir="mkdir -p /tmp/stellar-core/node01/history/vs/{0}"

Node2's history configuration

[HISTORY.local]
get="cp /tmp/stellar-core/node01/history/vs/{0} {1}"
put="cp {0} /tmp/stellar-core/node02/history/vs/{1}"
mkdir="mkdir -p /tmp/stellar-core/node02/history/vs/{0}"
  • Side note: on most systens /tmp will be cleared on reboot and is therefore not a good location. Better move it to somewhere else. – sui Jun 1 at 13:53
  • yeah agreed. thanks – Vishwas Bhushan Jun 3 at 5:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.