0

I am running a private stellar network and try to sync three nodes. From Node I am getting below message.

[Overlay DEBUG] Peer 127.0.0.1:11625 is not preferred

From Node3 getting below message [Overlay DEBUG] Peer 127.0.0.1:11625 is not preferred [Overlay DEBUG] Peer 127.0.0.1:11627 is not preferred.

I tried to solve these issue by putting below attribute one by one testing phase. In phase1, I have used CATCHUP_COMPLETE=false. In phase2, CATCHUP_COMPLETE=true,phase3 I have used CATCHUP_RECENT=1024 . But did not able to sync. Is there something I missed out.

0

At least you could most likely fix that debug message by adding all your nodes to the other nodes configs:

PREFERRED_PEERS=["127.0.0.1:11625", "127.0.0.1:11626", "127.0.0.1:11625"]

and/or

PREFERRED_PEER_KEYS=["GA...Node1PubKey", "GA...Node2PubKey", "GA...Node3PubKey"]

CATCHUP_RECENT=1 should work if there are no connection issues. For CATCHUP_COMPLETE all your nodes need to be able to access (ideally all your other nodes) archvies => check your archive configs. Completely resetting your malfunctioning node (or better spawning a fourth node to prevent accidentally data loss) might be an option. Post your config if you still have issues.

| improve this answer | |
  • In my case all there nodes are showing "Peer not preferred" , so is there any way to identify the malfunctioning node and config file archive. – Shan Gorai Nov 19 '19 at 14:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.