3

I'm trying to run the docker stellar/quickstart image. I launch it with:

docker run -d -p "8000:8000" --name stellar stellar/quickstart --testnet

I've left it running for quite some time but it never seems to connect to the network.

I checked the logs (/var/log/supervisor/horizon-stdout---supervisor-0LqSDF.log) and I'm seeing one error repeat itself:

time="2018-01-30T22:09:21Z" level=info msg="history db is empty, starting ingestion from ledger 0" pid=147
time="2018-01-30T22:09:21Z" level=error msg="import session failed: failed to load header: sql: no rows in result set" pid=147

Am I missing arguments? Any help would be appreciated.

EDIT: It seems to work when I remove the image and do a fresh download. But if I run docker rm -f <containerId> and launch a new container, that new container does not connect.

  • 1
    I use the following command (with xxx replaced with a real directory). With this command you can look at 'localhost:11626/info' for some more details: docker run -d --rm -it -p "8000:8000" -p "11626:11626" -p "11625:11625" -v "/xxx/xxx/xxx:/opt/stellar" --name stellar stellar/quickstart --pubnet – Jeff Jan 31 '18 at 15:18
  • Have you tried running it in -it mode? Or perhaps try and actually mount the instance with the -v command in -it mode. I've had some issues previously running undocked ephemeral instances. – Tyler van der Hoeven Feb 1 '18 at 13:33
  • Also what does docker -v produce and what OS are you running on? – Tyler van der Hoeven Feb 1 '18 at 13:36
  • Docker version 17.06.0 running on macOS Sierra. I've tried -it and -v . Only thing that seems to work is deleting the image between each container launched. – mecavity Feb 3 '18 at 21:20
1

Are you sure you are using the latest image available? It's possible that your image is cached on your disk while a new version is available in docker repository. Try this to remove the image:

docker rmi -f stellar/quickstart:latest

and then run your the container using a standard command.

  • 5
    When the image is outdated you can simply do docker pull stellar/quickstart:latest to fetch the latest version. You can see on docker hub when it was updated the last time: – alpe1 Jan 31 '18 at 10:56
  • 1
    @Bartek Nowotarski I've narrowed down the issue. It happens when I don't prune the image between containers. If I don't have the image locally I can run the command and it will connect. However if I run docker rm -f <containerId> and I run the docker run command again, it never connects to the network. Any idea why that would be? That might be more of a docker issue. – mecavity Feb 1 '18 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.