0

I have created a mult-sig account in Stellar. (All tests on TestNet). I created 3 regular accounts with secret key and public key. The first account I made multisig by adding Ed25519 signers. The other 2 signers are the other two accounts. I did this using set options transactions in Stellar Lab. I set threshold for medium and high to 2. Each signer has weight 1 and master weight is 1.

I successfully created and sent payment transaction using multisig with 2 signers in stellar laboratory.

I then added a ledger nano S account as a signer using set options transaction. I then created payment transaction and signed with one of the regular accounts and also signed with the ledger nano s. (2 signers) this was successful. I then added a ledger nano X signer. I also created a payment transaction and signed with one regular account and one ledger nano X signer. (2 signers) This was successful.

The account now has 5 signers. Any two of which should work.

I then created a new payment transaction and tried to sign with both Nano S and Nano X. Ie both signers are from two different Ledger Nano devices. This was not successful. I could sign with one but when I attacked and tried to sign with the other, it deleted the signature from the first one from the transactions. So I could never get more than one signature from any Ledger device at a time. This appears to be a bug. Should be able to have any number of signers from ledgers devices. Does anyone have a solution (besides a paid for multisig service).
Any chance of fixing this bug?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.