0

I am trying to learn about Stellar-core by configuring a full validator on the test network.

Using sample configs and input from this post, my config looks like:

BUCKET_DIR_PATH="/var/lib/stellar-core/buckets"
DATABASE="sqlite3:///var/lib/stellar-core/stellar.db"

ENTRY_CACHE_SIZE=4096
PREFETCH_BATCH_SIZE=1000
HTTP_PORT=11626
PUBLIC_HTTP_PORT=false
HTTP_MAX_CLIENT=128

COMMANDS=[
"ll?level=warning"
]

NODE_SEED="SA.................................."
NODE_IS_VALIDATOR=true

NETWORK_PASSPHRASE="Test SDF Network ; September 2015"
KNOWN_CURSORS=["HORIZON"]
UNSAFE_QUORUM=true
FAILURE_SAFETY=1
CATCHUP_RECENT=100

[[HOME_DOMAINS]]
HOME_DOMAIN="testnet.stellar.org"
QUALITY="HIGH"

[[HOME_DOMAINS]]
HOME_DOMAIN="stellar.howitts.co.uk"
QUALITY="HIGH"

[[VALIDATORS]]
NAME="sdf_testnet_1"
HOME_DOMAIN="testnet.stellar.org"
PUBLIC_KEY="GDKXE2OZMJIPOSLNA6N6F2BVCI3O777I2OOC4BV7VOYUEHYX7RTRYA7Y"
ADDRESS="core-testnet1.stellar.org"
HISTORY="curl -sf http://history.stellar.org/prd/core-testnet/core_testnet_001/{0} -o {1}"

[[VALIDATORS]]
NAME="sdf_testnet_2"
HOME_DOMAIN="testnet.stellar.org"
PUBLIC_KEY="GCUCJTIYXSOXKBSNFGNFWW5MUQ54HKRPGJUTQFJ5RQXZXNOLNXYDHRAP"
ADDRESS="core-testnet2.stellar.org"
HISTORY="curl -sf http://history.stellar.org/prd/core-testnet/core_testnet_002/{0} -o {1}"

[[VALIDATORS]]
NAME="sdf_testnet_3"
HOME_DOMAIN="testnet.stellar.org"
PUBLIC_KEY="GC2V2EFSXN6SQTWVYA5EPJPBWWIMSD2XQNKUOHGEKB535AQE2I6IXV2Z"
ADDRESS="core-testnet3.stellar.org"
HISTORY="curl -sf http://history.stellar.org/prd/core-testnet/core_testnet_003/{0} -o {1}"

[HISTORY.local]
get="cp /var/lib/stellar-core/history/vs/{0} {1}"
put="cp {0} /var/lib/stellar-core/history/vs/{1}"
mkdir="mkdir -p /var/lib/stellar-core/history/vs/{0}"

But this does not seem to be working and I get the following error when trying to create a db:

[root@proxmox107 ~]# runuser -l stellar -c '/usr/bin/stellar-core --conf /etc/stellar-core/stellar.cfg new-db'
runuser: warning: cannot change directory to /home/stellar: No such file or directory
2021-03-22T15:15:33.190 [default INFO] Config from /etc/stellar-core/stellar.cfg
2021-03-22T15:15:33.192 [default FATAL] Got an exception: Failed to parse '/etc/stellar-core/stellar.cfg' :Must specify a matching HOME_DOMAINS for self
2021-03-22T15:15:33.192 [default FATAL] Please report this bug along with this log file if this was not expected

I am really not sure where to go on this one. In the examples I've seen I don't see HOME_DOMAIN or HOME_DOMAINS set. What should the HOME_DOMAINS be matching with?

I also do not see where I should set my key's home domain. I have created a key at Stellar Labs but I don't see where to add my home domain.

As I've only got this far, I have not set up a toml file (or even enabled the web server)

Can someone please point me in the right direction?

0

I think the error is just misleading. The field that you're supposed to set is NODE_HOME_DOMAIN that must match your domain.

I opened https://github.com/stellar/stellar-core/pull/2987 to fix this in both the error code and docs

1
  • Thanks for your answer. I was experimenting this morning before I saw your answer. From my experimenting, it looks like both NODE_HOME_DOMAIN and HOME_DOMAIN must be set and the same or you can't do a new-db. If you set one without the other, or set them differently, it does not work, so it seems like a further bug and one of the parameters could be made redundant. There also does not seem to be a check on the parameter as you can set it to anything (I tried anything.here and it worked as long as both were set). I can understand that. I have commented on your bug report.
    – NickH
    Mar 30 at 11:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.