0

I am trying to change the network passphrase for stellar. I am using the quickstart docker image and launching in standalone mode.

command:

docker run --rm -it -p "8000:8000" -v "E:\Google Drive\Actual Projects\Stellar:/opt/stellar" --name stellar stellar/quickstart --standalone

I've tried editing all the available config file in "E:\Google Drive\Actual Projects\Stellar" etc subdirectories.

However when doing so errors are produced and it seems to not actually change the key.

for instancing after changing the key I get the following:

PS C:\Users\Isaac> docker run --rm -it -p "8000:8000" -v "E:\Google Drive\Actual Projects\Stellar:/opt/stellar" --name stellar stellar/quickstart --standalone

Starting Stellar Quickstart

mode: persistent
network: standalone (Standalone Network ; February 2017)
postgres: config directory exists, skipping copy
supervisor: config directory exists, skipping copy
stellar-core: config directory exists, skipping copy
horizon: config directory exists, skipping copy
postgres: already initialized
chown-core: ok
core: already initialized
Waiting for postgres to be available...
postgres: up
init-core-scp: ok
horizon: already initialized
postgres: down
starting supervisor
2021-04-25 18:29:18,298 CRIT Supervisor is running as root.  Privileges were not dropped because no user is specified in the config file.  If you intend to run as root, you can set user=root in the config file to avoid this message.
2021-04-25 18:29:18,306 INFO RPC interface 'supervisor' initialized
2021-04-25 18:29:18,307 CRIT Server 'unix_http_server' running without any HTTP authentication checking
2021-04-25 18:29:18,307 INFO supervisord started with pid 1
2021-04-25 18:29:19,310 INFO spawned: 'postgresql' with pid 59
2021-04-25 18:29:19,322 INFO spawned: 'stellar-core' with pid 60
2021-04-25 18:29:19,332 INFO spawned: 'horizon' with pid 61
2021-04-25 18:29:20,561 INFO success: postgresql entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
2021-04-25 18:29:20,562 INFO success: stellar-core entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
2021-04-25 18:29:20,562 INFO success: horizon entered RUNNING state, process has stayed up for > than 1 seconds (startsecs)
2021-04-25 18:29:20,886 INFO exited: stellar-core (exit status 1; not expected)
2021-04-25 18:29:20,971 INFO spawned: 'stellar-core' with pid 140
2021-04-25 18:29:21,204 INFO exited: stellar-core (exit status 1; not expected)
2021-04-25 18:29:22,969 INFO spawned: 'stellar-core' with pid 173
2021-04-25 18:29:23,192 INFO exited: stellar-core (exit status 1; not expected)

network: standalone (Standalone Network ; February 2017) is still showing as the key though I have changed multiple files.

Any help on how to setup this up with my desired key would be greatly appreciated!

Files edited:

enter image description here

Same error as here: FATAL when switching from test network to public network on stellar-core

No fix provided at that link either.

Some other tings I've tried:

Updating the stellar conf in the HOME directory when I exec into the docker image.

running stellar-core new-db

and stellar-core new-hist

UPDATE:

Okay so after editing the conf files. and running the above commands

I still see the old network key show in the PS log but the actualt log files for the staller docker imagine have the following:

2021-04-25T18:58:33.511 GCTI6 [default INFO] Starting stellar-core stellar-core 16.0.0 (0e35ac6ef382391096dbe4443197051452a3ce50)
2021-04-25T18:58:33.513 GCTI6 [Database INFO] Connecting to: postgresql://dbname=core host=localhost user=stellar password=********
2021-04-25T18:58:33.570 GCTI6 [SCP INFO] LocalNode::LocalNode@GCTI6 qSet: d05a3b
2021-04-25T18:58:33.577 GCTI6 [default INFO] Listening on 0.0.0.0:11626 for HTTP requests
2021-04-25T18:58:33.582 GCTI6 [Database INFO] DB schema is in current version
2021-04-25T18:58:33.587 GCTI6 [History INFO] Archive 'vs' has 'put' and 'get' commands, will be read and written
2021-04-25T18:58:33.587 GCTI6 [Ledger INFO] Starting up application
2021-04-25T18:58:33.587 GCTI6 [default INFO] Connection effective settings:
2021-04-25T18:58:33.588 GCTI6 [default INFO] TARGET_PEER_CONNECTIONS: 8
2021-04-25T18:58:33.588 GCTI6 [default INFO] MAX_ADDITIONAL_PEER_CONNECTIONS: 64
2021-04-25T18:58:33.588 GCTI6 [default INFO] MAX_PENDING_CONNECTIONS: 500
2021-04-25T18:58:33.588 GCTI6 [default INFO] MAX_OUTBOUND_PENDING_CONNECTIONS: 56
2021-04-25T18:58:33.588 GCTI6 [default INFO] MAX_INBOUND_PENDING_CONNECTIONS: 444
2021-04-25T18:58:33.588 GCTI6 [Ledger INFO] Last closed ledger (LCL) hash is 7fd08214703fffa537e8907bfe83da4001f3673bd75ed90f0abcc2c5a8b62c0b
2021-04-25T18:58:33.594 GCTI6 [Ledger INFO] Loaded LCL header from database: [seq=1, hash=7fd082]
2021-04-25T18:58:33.600 GCTI6 [Ledger ERROR] 1 buckets are missing from bucket directory 'buckets'
2021-04-25T18:58:33.601 GCTI6 [default FATAL] Got an exception: Bucket directory is corrupt
2021-04-25T18:58:33.601 GCTI6 [default FATAL] Please report this bug along with this log file if this was not expected
2021-04-25T18:58:33.602 GCTI6 [default INFO] Application destructing
2021-04-25T18:58:33.604 GCTI6 [default INFO] Application destroyed

so It seems I have either caused more issues and haven't hit the network keys not matched error or I'm passed that and hitting a corrupt with the buckets. Though I don't know what that would be or how to fix it. I can also delete the mounted directory contents and go back to square one if needed. Though I have done that many time now as well.

0
0

I think you just forgot to update the Docker's image start file that contains the following:

export NETWORK_PASSPHRASE="Standalone Network ; February 2017"

As you did a bunch of other experiments, it's probably better to rebuild the container from scratch after editing the passphrase.

1
  • Thank that has made some forward progress! So i found the file and was able to change it. I then had to manually change the stellar-core.cfg files still as they copy premade files from stellar-core-default within the container. The problem is now we get back to the bucket issue. and running stellar-core new-db doesn't fix it. I tried running stellar-core new-hist as I believe the buckets and history are inherently linked but I'm not sure. Any insight you can offer in this instance? See the last image on my thread. Its basically that again. The key does seem to be changed though.
    – user4098
    Apr 30 at 3:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.