4

As the title suggests I'm having some difficulty installing stellar-quickstart via packages.

my system details:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 20.04.2 LTS
Release:    20.04
Codename:   focal

Although the Getting Started guide doesn't mention it, I started by adding the SDF stable repository to my system.

My system shows the following:

$ cat SDF.list 
deb [arch=amd64] https://apt.stellar.org focal stable

Note: I added the [arch=amd64] piece to get around a "does not support i386" warning. EDIT: In case it's useful, this was the message I was getting before I added the [arch=amd64]:

N: Skipping acquire of configured file 'stable/binary-i386/Packages' as repository 'https://apt.stellar.org focal InRelease' doesn't support architecture 'i386'

Still, though, my system does not find stellar-quickstart:

$ sudo apt-get update && sudo apt-get install stellar-quickstart
Hit:1 http://us.archive.ubuntu.com/ubuntu focal InRelease
Hit:2 http://security.ubuntu.com/ubuntu focal-security InRelease                                                                                                               
Hit:3 http://us.archive.ubuntu.com/ubuntu focal-updates InRelease                                                                                                              
Hit:4 http://us.archive.ubuntu.com/ubuntu focal-backports InRelease                                                                                                            
Hit:5 https://apt.releases.hashicorp.com focal InRelease                                                                                                                       
Hit:6 http://ppa.launchpad.net/forkotov02/ppa/ubuntu focal InRelease                                                                                                           
Hit:7 https://apt.stellar.org focal InRelease                       
Get:8 https://dl.cloudsmith.io/public/balena/etcher/deb/ubuntu focal InRelease [5,054 B]
Fetched 5,054 B in 1s (3,578 B/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package stellar-quickstart

Interestingly (or maybe not?) I was able to install stellar-core and stellar-horizon with no trouble at all.

So, question is: What do I need to do to install stellar-quickstart?

3
  • 2
    The Stellar github docs recommend how to add the SDF stable repository to a debian based system github.com/stellar/packages/blob/master/docs/… , but the next page Quickstart installation instructions simply do not work as written. You still get the same unable to locate package error that you described. Jun 1 at 19:59
  • 1
    Ok good to know someone has also run into this. I'll open a ticket.
    – Ramy
    Jun 2 at 1:55
  • 1
    I asked about this topic on the Keybase Stellar group and was directed to these docs instead: developers.stellar.org/docs/run-api-server . There are still some gaps in information, but apparently these are considerd to be more current. Jun 2 at 18:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.