1

I tried to use Polaris 2.1.0 deployed in kubernetes. sep-24 deposit did not work in demo-wallet using I created test token (when I used Polaris 1.6.4, it worked).

When I tried sep-24 deposit, Error message show DoesNotExist at /sep24/transactions/deposit/webapp/submit OffChainAssetExtra matching query does not exist.

How can I solve these problems? in Polaris 2.1.0, admin UI has changed from 1.6.4, and I am not sure configurations (Delivery methods, Exchange pairs ...) are correctly configured.

1

First I would upgrade to the latest patch release, 2.1.2.

It sounds like you don't have the necessary database entries to run the example server successfully. Our example server demonstrates how off-chain assets can be exchanged for different on-chain assets, so the example server has some new models.

If you want to run the example server, you need to create an USD OffChainAsset record, as well as a OffChainAssetExtra record. Then, you can create an ExchangePair record for USD and SRT. Finally, you'll want to add at least one DeliveryMethod record associated with the USD off-chain asset record.

These are the records our example server requires to run its implementation of the Stellar ecosystem protocols, but if you implement your own anchor using Polaris you do not have to add these database records if you don't need to support exchanges of non-equivalent on & off-chain assets.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.