0

I have set up one stellar private network. Now I want to connect horizon with that private network core in captive mode. So that I have create one stellar-captive-core.cfg file as below

[[HOME_DOMAINS]]
HOME_DOMAIN="bitpaymentz.com"
QUALITY="HIGH"

[[VALIDATORS]]
NAME="Node1"
HOME_DOMAIN="bitpaymentz.com"
PUBLIC_KEY="GD6IY3XE3QVR32WULTVU643F3TDJNHOUQJUJTCMD4TWSCQCXUIZIIUFQ"
HISTORY="curl -sf file:///tmp/Node1/stellar-core/history/vs/"

[[VALIDATORS]]
NAME="Node2"
HOME_DOMAIN="bitpaymentz.com"
PUBLIC_KEY="GADDCNNR7O3VOREM5YGLFB3G7LP6RGTDHVCH7T3KO5Y7WRBOAN2GADFA"
HISTORY="curl -sf file:///tmp/Node2/stellar-core/history/vs/"

[[VALIDATORS]]
NAME="Node3"
HOME_DOMAIN="bitpaymentz.com"
PUBLIC_KEY="GC2V2EFSXN6SQTWVYA5EPJPBWWIMSD2XQNKUOHGEKB535AQE2I6IXV2Z"
HISTORY="curl -sf file:///tmp/Node1/stellar-core/history/vs/"

I have ran the captive core and it is running in 8001 port. After that I ran horizon with ----remote-captive-core-url flag and it is running successfully with 8000 port. But during ingestion horizon giving error it's saying, "does match network passphrase, it should be Test SDF Network ; September 2015" But in my stellar-captive-core.cfg file I have mentioned my configuration not stellar configuration.

1 Answer 1

0

Try adding NETWORK_PASSPHRASE=Test SDF Network ; September 2015 to the environment variable, or via --network-passphrase=Test SDF Network ; September 2015

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.