3

I created a Stellar Private Network using the installation instructions from https://github.com/stellar/packages#sdf---packages. Everything worked well.

But when I try to use sha256 hash for multi-sig, it doesn't work. I get the error op_bad_signer.

This hash can be used on Testnet. 49bd3b8bc1cde1b78640e14ce5fdc2c982ce88139c2e3a473e270d46900bcfb8

Things I have tried that have failed:

  1. Create js-stellar-sdk to submit transaction.
  2. Send XDR envelope directly to stellar-core.
  3. Installed Stellar laboratory on my Stellar Private Network tried SetOptions.

Do I need to set up something to enable this feature?

7
  • Can you post your transaction in XDR format? Commented Mar 2, 2018 at 19:58
  • "extras": { "envelope_xdr": "AAAAALHG+wCSBnrRvXqbsZ7Y9Uhz2W5AVaZgAmzuXlmbTRHFAAAAZAAAU34AAAABAAAAAAAAAAAAAAABAAAAAAAAAAUAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAEAAAACSb07i8HN4beGQOFM5f3CyYLOiBOcLjpHPicNRpALz7gAAAABAAAAAAAAAAGbTRHFAAAAQIlkVga0KhrDmLVXpDeBEcamniLRblTD20Z70w3y+bRe0kzxGZ0Dtifq4jurhD8TE4+Ox2NltvI9L7ebg36Y0gk=", "result_codes": { "transaction": "tx_failed", "operations": [ "op_bad_signer" ] }, "result_xdr": "AAAAAAAAAGT/////AAAAAQAAAAAAAAAF////+AAAAAA=" } Commented Mar 5, 2018 at 3:19
  • var crypto = require('crypto'); var genHash = key => crypto.createHash('sha256').update(key).digest('hex'); genHash('dfdsfsfsffsdfdsfdsfdsfdsdsfsd8') => '49bd3b8bc1cde1b78640e14ce5fdc2c982ce88139c2e3a473e270d46900bcfb8' Commented Mar 5, 2018 at 3:22
  • OK, so you're saying that this works on testnet but doesn't work in your private network? You you link to the transaction that succeeded in testnet? Commented Mar 8, 2018 at 18:28
  • I create new account and SetOptions with sha256Hash on testnet. horizon-testnet.stellar.org/transactions/… Commented Mar 9, 2018 at 4:09

1 Answer 1

1

I found solutions by myself. After create Stellar Private Network, We must execute command to upgrade protocolversion to 9.

$ stellar-core -c 'upgrades?mode=set&upgradetime=2018-01-31T20:00:00Z&protocolversion=9'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.