0

this is what i get in terminal output:

C:\Users\admin> cargo install --locked soroban-cli

DEBUG: 1+ >>>> cargo install --locked soroban-cli Updating crates.io index Installing soroban-cli v20.3.4 Updating crates.io index Updating crates.io index Compiling proc-macro2 v1.0.69 Compiling unicode-ident v1.0.12 Compiling serde v1.0.192 Compiling autocfg v1.1.0 Compiling cfg-if v1.0.0 Compiling thiserror v1.0.55 Compiling once_cell v1.19.0 Compiling windows_x86_64_msvc v0.52.0 Compiling memchr v2.7.1 Compiling itoa v1.0.10 Compiling quote v1.0.33 Compiling syn v2.0.39 Compiling windows-targets v0.52.0 Compiling windows-sys v0.52.0 Compiling version_check v0.9.4 Compiling typenum v1.17.0 Compiling smallvec v1.13.1 Compiling winapi v0.3.9 Compiling bytes v1.5.0 Compiling windows_x86_64_msvc v0.48.5 error[E0786]: found invalid metadata files for crate compiler_builtins which std depends on | = note: failed to mmap file '\?\C:\Users\admin.rustup\toolchains\stable-x86_64-pc-windows-msvc\lib\rustlib\x86_64-pc-windows-msvc\lib\libcompiler_builtins-34df001b737926cd.rlib': The paging file is too small for this operation to complete. (os error 1455)

memory allocation of 2096640 bytes failed error: cannot find macro println in this scope --> C:\Users\admin.cargo\registry\src\index.crates.io-6f17d22bba15001f\windows_x86_64_msvc-0.48.5\build.rs:9:5 | 9 | println!("cargo:rustc-link-search=native={}", std::path::Path::new(&dir).join("lib").display()); | ^^^^^^^

error[E0462]: found staticlib std instead of rlib or dylib --> C:\Users\admin.cargo\registry\src\index.crates.io-6f17d22bba15001f\windows_x86_64_msvc-0.48.5\build.rs:2:18 | 2 | let target = std::env::var("TARGET").unwrap(); | ^^^ | = note: the following crate versions were found: crate std: C:\Users\admin.rustup\toolchains\stable-x86_64-pc-windows-msvc\lib\rustlib\x86_64-pc-windows-msvc\lib\std-49e3d1aefc00cc02.dll.lib = help: please recompile that crate using --crate-type lib

error[E0462]: found staticlib std instead of rlib or dylib --> C:\Users\admin.cargo\registry\src\index.crates.io-6f17d22bba15001f\windows_x86_64_msvc-0.48.5\build.rs:7:15 | 7 | let dir = std::env::var("CARGO_MANIFEST_DIR").unwrap(); | ^^^ | = note: the following crate versions were found: crate std: C:\Users\admin.rustup\toolchains\stable-x86_64-pc-windows-msvc\lib\rustlib\x86_64-pc-windows-msvc\lib\std-49e3d1aefc00cc02.dll.lib = help: please recompile that crate using --crate-type lib

error: #[panic_handler] function required, but not found

error: unwinding panics are not supported without std | = help: using nightly cargo, use -Zbuild-std with panic="abort" to avoid unwinding = note: since the core library is usually precompiled with panic="unwind", rebuilding your crate with panic="abort" may not be enough to fix the problem

error: requires sized lang_item

Some errors have detailed explanations: E0462, E0786. For more information about an error, try rustc --explain E0462. error: could not compile windows_x86_64_msvc (build script) due to 7 previous errors warning: build failed, waiting for other jobs to finish... memory allocation of 1300736 bytes failed error: could not compile windows-sys (lib)

Caused by: process didn't exit successfully: C:\Users\admin\.rustup\toolchains\stable-x86_64-pc-windows-msvc\bin\rustc.exe --crate-name windows_sys --edition=2021 C:\Users\admin\.cargo\registry\src\index.crates.io-6f17d22bba15001f\windows-sys-0.52.0\src\lib.rs --error-format=json --json=diagnostic-rendered-ansi,artifacts,future-incompat --diagnostic-width=145 --crate-type lib --emit=dep-info,metadata,link -C opt-level=3 -C embed-bitcode=no --cfg "feature=\"Win32\"" --cfg "feature=\"Win32_Foundation\"" --cfg "feature=\"Win32_NetworkManagement\"" --cfg "feature=\"Win32_NetworkManagement_IpHelper\"" --cfg "feature=\"Win32_Networking\"" --cfg "feature=\"Win32_Networking_WinSock\"" --cfg "feature=\"Win32_Security\"" --cfg "feature=\"Win32_Security_Authentication\"" --cfg "feature=\"Win32_Security_Authentication_Identity\"" --cfg "feature=\"Win32_Security_Authorization\"" --cfg "feature=\"Win32_Security_Credentials\"" --cfg "feature=\"Win32_Security_Cryptography\"" --cfg "feature=\"Win32_Storage\"" --cfg "feature=\"Win32_Storage_FileSystem\"" --cfg "feature=\"Win32_System\"" --cfg "feature=\"Win32_System_Com\"" --cfg "feature=\"Win32_System_Console\"" --cfg "feature=\"Win32_System_Diagnostics\"" --cfg "feature=\"Win32_System_Diagnostics_Debug\"" --cfg "feature=\"Win32_System_Memory\"" --cfg "feature=\"Win32_System_Threading\"" --cfg "feature=\"Win32_UI\"" --cfg "feature=\"Win32_UI_Shell\"" --cfg "feature=\"default\"" -C metadata=71e6f15bfb9843c9 -C extra-filename=-71e6f15bfb9843c9 --out-dir C:\Users\admin\AppData\Local\Temp\cargo-install0pJ2NA\release\deps -L dependency=C:\Users\admin\AppData\Local\Temp\cargo-install0pJ2NA\release\deps --extern windows_targets=C:\Users\admin\AppData\Local\Temp\cargo-install0pJ2NA\release\deps\libwindows_targets-8b73114dfc772279.rmeta --cap-lints allow -L native=C:\Users\admin\.cargo\registry\src\index.crates.io-6f17d22bba15001f\windows_x86_64_msvc-0.52.0\lib (exit code: 0xc0000409, STATUS_STACK_BUFFER_OVERRUN) error: could not compile winapi (lib)

Caused by: process didn't exit successfully: C:\Users\admin\.rustup\toolchains\stable-x86_64-pc-windows-msvc\bin\rustc.exe --crate-name winapi --edition=2015 C:\Users\admin\.cargo\registry\src\index.crates.io-6f17d22bba15001f\winapi-0.3.9\src\lib.rs --error-format=json --json=diagnostic-rendered-ansi,artifacts,future-incompat --diagnostic-width=145 --crate-type lib --emit=dep-info,metadata,link -C opt-level=3 -C embed-bitcode=no --cfg "feature=\"consoleapi\"" --cfg "feature=\"errhandlingapi\"" --cfg "feature=\"fileapi\"" --cfg "feature=\"handleapi\"" --cfg "feature=\"knownfolders\"" --cfg "feature=\"minwindef\"" --cfg "feature=\"objbase\"" --cfg "feature=\"processenv\"" --cfg "feature=\"shlobj\"" --cfg "feature=\"std\"" --cfg "feature=\"sysinfoapi\"" --cfg "feature=\"winbase\"" --cfg "feature=\"wincon\"" --cfg "feature=\"winerror\"" --cfg "feature=\"winnt\"" --cfg "feature=\"winsock2\"" -C metadata=ba0f128c5e3ee35f -C extra-filename=-ba0f128c5e3ee35f --out-dir C:\Users\admin\AppData\Local\Temp\cargo-install0pJ2NA\release\deps -L dependency=C:\Users\admin\AppData\Local\Temp\cargo-install0pJ2NA\release\deps --cap-lints allow -l dylib=advapi32 -l dylib=cfgmgr32 -l dylib=gdi32 -l dylib=kernel32 -l dylib=msimg32 -l dylib=ole32 -l dylib=opengl32 -l dylib=shell32 -l dylib=user32 -l dylib=winspool -l dylib=ws2_32 --cfg "feature=\"cfg\"" --cfg "feature=\"oaidl\"" --cfg "feature=\"rpcdce\"" --cfg "feature=\"vadefs\"" --cfg "feature=\"libloaderapi\"" --cfg "feature=\"shtypes\"" --cfg "feature=\"devpropdef\"" --cfg "feature=\"wtypesbase\"" --cfg "feature=\"ws2def\"" --cfg "feature=\"minwinbase\"" --cfg "feature=\"unknwnbase\"" --cfg "feature=\"wtypes\"" --cfg "feature=\"wingdi\"" --cfg "feature=\"excpt\"" --cfg "feature=\"combaseapi\"" --cfg "feature=\"objidl\"" --cfg "feature=\"processthreadsapi\"" --cfg "feature=\"rpcndr\"" --cfg "feature=\"ntdef\"" --cfg "feature=\"vcruntime\"" --cfg "feature=\"inaddr\"" --cfg "feature=\"qos\"" --cfg "feature=\"basetsd\"" --cfg "feature=\"propidl\"" --cfg "feature=\"windef\"" --cfg "feature=\"reason\"" --cfg "feature=\"winreg\"" --cfg "feature=\"ktmtypes\"" --cfg "feature=\"ntstatus\"" --cfg "feature=\"guiddef\"" --cfg "feature=\"wincontypes\"" --cfg "feature=\"rpc\"" --cfg "feature=\"cfgmgr32\"" --cfg "feature=\"objidlbase\"" (exit code: 0xc0000409, STATUS_STACK_BUFFER_OVERRUN) error: failed to compile soroban-cli v20.3.4, intermediate artifacts can be found at C:\Users\admin\AppData\Local\Temp\cargo-install0pJ2NA. To reuse those artifacts with a future compilation, set the environment variable CARGO_TARGET_DIR to that path. PS C:\Users\admin>

  • History restored

C:\Users\admin> soroban soroban : The term 'soroban' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again. At line:1 char:1

  • soroban
  •   + CategoryInfo          : ObjectNotFound: (soroban:String) [], CommandNotFoundException
      + FullyQualifiedErrorId : CommandNotFoundException
    
    
0

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.