3

I have the following public address:

GAUXOMOELZVPX6RTKTZHR4MFGBMLHRKSGLBGBTXBW2J7AKCBG7E3OLP3

I tried funding the account in node js with

request('https://horizon-testnet.stellar.org/friendbot?addr=GAUXOMOELZVPX6RTKTZHR4MFGBMLHRKSGLBGBTXBW2J7AKCBG7E3OLP3',function(err,res,body){
  console.log(body);
});

The body gave the default endpoint for the /friendbot without a tx hash.

Then, I tried to fund the same account with

https://www.stellar.org/laboratory/#account-creator?network=test

It said that it was successful, yet nothing shows up in the testnet explorer:

https://stellar.expert/explorer/testnet/account/GAUXOMOELZVPX6RTKTZHR4MFGBMLHRKSGLBGBTXBW2J7AKCBG7E3OLP3

What am I doing wrong?

2

Friendbot intermittently failing to fund account

The issue persists. Yesterday it worked, but today not.

Until they close this issue, I think it's safer for you to use "Create Account" operation with their given set to set up your account.

Step 1, Generate Keypair

Step 2, "Create Account" with the following pair (<= 1000 lumen acceptable?)

Public Key    GBW74UVOXKGHO3WX6AV5ZGTB4JYBKCEJOUQAUSI25NRO3PKY5BC7WYZS
Secret Key    SA3W53XXG64ITFFIYQSBIJDG26LMXYRIMEVMNQMFAQJOYCZACCYBA34L
  • Thanks for the info - Just for my understanding of the network, do you know why the testbot sometimes doesn't work? I am planning to create an app that allows for automatic funding of new accounts and would prefer not to have something like this happen on the mainnet. – nEKN53 Mar 17 '18 at 3:10
  • For years, friendbot was a function in Horizon. In a recent Horizon release (Jan/Feb 2018), they decided to separate this function to be a stand-alone application. github.com/stellar/go/releases – cesarm Mar 19 '18 at 2:00
  • p.s. I have been running a private network to play with, and it is still running Horizon v0.11. I can say v0.11 is rather reliable up to now, and would not upgrade until I see it safe. github.com/stellar/horizon/releases – cesarm Mar 19 '18 at 2:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.