4

Dear Stellar entusiastas,

I am set up a bridge server in the google cloud. When running the bridge server, I have this kind of error:

ERRO[0200] Error while streaming: only expected 1 event, got: 0  service=PaymentListener
INFO[0200] Sleeping...                                   service=PaymentListener

I already opened port 8006 for https in my firewall, but no success. The docs havent any mention to this error. An https service open in the 8006 port does not seems enought to get this running... Must I have do any adittional configuration?

Thanks advanced

EDIT:

After some modifications on my firewall rules in the server, I continue having the same error message reported above, but when trying create a transaction

{
  "code": "internal_server_error",
  "message": "Internal Server Error, please try again."
}

and in the server side, I had the following response:

INFO[0688] Error signing a transaction                   service=TransactionSubmitter
ERRO[0688] Error submitting transaction                  error="cannot sign"
1

The bridge server is watching the configured stellar accountID for incoming payments events via horizon stream api and iterating over it. The error could appear when the response was not empty but did not contain payment events. Do you run a recent version of horizon + bridge server? I can not replicate the issue.

To help debugging the issue, please check the response of your accountID. You may need to iterate via cursor query parameter if you have a long list.

curl -X GET "https://horizon-testnet.stellar.org/accounts/<your-accountID>/payments" -H "ACCEPT: text/event-stream"

  • Thanks for your reply! your curl command helps me to check some other missing points in my bridge installation. It works now, but, as comment by @sacarlson, the error message remains but with no other effects – horatio May 19 '18 at 0:05
0

seem's I might be having the same problem on my bridge-server. I may have created a duplicate report here: Problem with bridge-server ERRO[0062] seen every 60 sec. Note this was working for 12 months without a problem on testnet. I also have the same bridge-server code running on livenet without error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.