Questions tagged [buckets]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
1 answer
64 views

Error merging bucket, and FATAL SCP crash

I have a private network based on Stellar core v.10 with 3 nodes and 66% 2/3 consensus, after 6 month successfully worked this network crash with message: insufficient buffer space in xdr_generic_get....
user avatar
  • 13
3 votes
1 answer
219 views

Publishing history to new history archive results in error of loading history state

I keep getting the [History ERROR] Error loading history state: rapidjson internal assertion failure: IsObject() when trying to publish the state of a recently added node to it's recently initialized ...
user avatar
6 votes
2 answers
113 views

Huge temporary bucket files created - and then destroyed on all cores. Is this normal?

I'm maintaining a network of Stellar nodes with quite a lot of traffic, for quite some time now (almost half a year). Everything has been quite stable so far, but last week I noticed that all the core ...
user avatar
  • 1,581
5 votes
1 answer
86 views

How to handle docker container restarts with persistent data and missing buckets

I have a private network of Stellar core nodes running on docker swarm with the DB and ledger data persisted correctly. When I remove or update the service for maintenance/upgrade of the docker image ...
user avatar
  • 207
5 votes
1 answer
264 views

Stellar-core not syncing on testnet after restart. Missing Buckets not being retrieved

After attempting to restart a stellar core node I had running on the test net I got an error, and when I tried to run stellar-core (inside docker container) with stellar-core run I got the following: ...
user avatar