0

I am using stellar-core in ubuntu 18.04 . I want to create test-network . But my node is unable to sync , it is stuck showing the log

    For new syntax: stellar-core help

2019-06-07T11:38:26.889 GDRLE [default INFO] Starting stellar-core stellar-core 11.1.0 (324c1bd61b0e9bada63e0d696d799421b00a7950)
2019-06-07T11:38:26.902 GDRLE [Database INFO] Connecting to: postgresql://dbname=testnet host=localhost user=minhajs password=********
2019-06-07T11:38:26.922 GDRLE [SCP INFO] LocalNode::LocalNode@GDRLE qSet: 273af2
2019-06-07T11:38:26.922 GDRLE [default INFO] Listening on 127.0.0.1:11626 for HTTP requests
2019-06-07T11:38:26.930 GDRLE [Database INFO] DB schema is in current version
2019-06-07T11:38:26.931 GDRLE [History INFO] Archive 'h1' has 'get' command only, will not be written
2019-06-07T11:38:26.931 GDRLE [History INFO] Archive 'h2' has 'get' command only, will not be written
2019-06-07T11:38:26.931 GDRLE [History INFO] Archive 'h3' has 'get' command only, will not be written
2019-06-07T11:38:26.932 GDRLE [History WARNING] No writable archives configured, history will not be written.
2019-06-07T11:38:26.932 GDRLE [Ledger INFO] Starting up application
2019-06-07T11:38:26.934 GDRLE [default INFO] Connection effective settings:
2019-06-07T11:38:26.934 GDRLE [default INFO] TARGET_PEER_CONNECTIONS: 8
2019-06-07T11:38:26.934 GDRLE [default INFO] MAX_ADDITIONAL_PEER_CONNECTIONS: 64
2019-06-07T11:38:26.934 GDRLE [default INFO] MAX_PENDING_CONNECTIONS: 500
2019-06-07T11:38:26.934 GDRLE [default INFO] MAX_OUTBOUND_PENDING_CONNECTIONS: 16
2019-06-07T11:38:26.934 GDRLE [default INFO] MAX_INBOUND_PENDING_CONNECTIONS: 484
2019-06-07T11:38:26.934 GDRLE [default INFO] Loading last known ledger
2019-06-07T11:38:26.940 GDRLE [Ledger INFO] Loaded last known ledger: [seq=1, hash=9c0fc9]
2019-06-07T11:38:26.941 GDRLE [Overlay INFO] Binding to endpoint 0.0.0.0:11625
2019-06-07T11:38:26.943 GDRLE [default INFO] * 
2019-06-07T11:38:26.943 GDRLE [default INFO] * Force-starting scp from the current db state. (`force scp` flag cleared in the db)
2019-06-07T11:38:26.943 GDRLE [default INFO] * 
2019-06-07T11:38:26.943 GDRLE [Herder INFO] Force joining SCP with local state
2019-06-07T11:38:26.943 GDRLE [Ledger INFO] Changing state LM_BOOTING_STATE -> LM_SYNCED_STATE
2019-06-07T11:39:01.941 GDRLE [Herder WARNING] Lost track of consensus
2019-06-07T11:39:01.942 GDRLE [Herder WARNING] Out of sync context: {
   "queue" : null,
   "scp" : {
      "2" : {
         "ballotProtocol" : {
            "ballot" : "(<null_ballot>)",
            "heard" : false,
            "phase" : "PREPARE",
            "state" : "i: 2 | PREPARE | b: (<null_ballot>) | p: (<null_ballot>) | p': (<null_ballot>) | h: (<null_ballot>) | c: (<null_ballot>) | M: 0"
         },
         "nomination" : {
            "X" : [ "[ txH: 392ada, ct: 1559887706, upgrades: [ ] ]" ],
            "roundnumber" : 8,
            "started" : true
         },
         "quorum_sets" : {
            "273af2" : {
               "t" : 2,
               "v" : [ "sdf1", "sdf2", "sdf3" ]
            }
         },
         "statements" : [
            [
               1559887709,
               "{ENV@GDRLE |  i: 2 | NOMINATE | D: 273af2 | X: {'[ txH: 392ada, ct: 1559887706, upgrades: [ ] ]'} | Y: {} }",
               true
            ]
         ],
         "validated" : true
      }
   },
   "you" : "GDRLEVIYCSPF4Z5ZPPNURZGF7GTBDCBVSDLCD3Y5C6KJTVHO43HWHOF6"
}

. My configuration file is

HTTP_PORT=11626
PUBLIC_HTTP_PORT=false
PEER_PORT=11625

NETWORK_PASSPHRASE="Test network"
RUN_STANDALONE=false
KNOWN_PEERS=[
"core-testnet1.stellar.org",
"core-testnet2.stellar.org",
"core-testnet3.stellar.org"]



DATABASE="postgresql://dbname=testnet host=localhost user=minhajs password=minhajs"
NODE_SEED="SBTBCMET7YMAMYXF2KSV63CSRLDMD5AO3FDELN4HCPY6UR2KBZBASRF6"
#Public: GDRLEVIYCSPF4Z5ZPPNURZGF7GTBDCBVSDLCD3Y5C6KJTVHO43HWHOF6

NODE_IS_VALIDATOR=true

UNSAFE_QUORUM=true
FAILURE_SAFETY=1

#The public keys of the Stellar testnet servers
[QUORUM_SET]
THRESHOLD_PERCENT=51 # rounded up -> 2 nodes out of 3
VALIDATORS=[
"GDKXE2OZMJIPOSLNA6N6F2BVCI3O777I2OOC4BV7VOYUEHYX7RTRYA7Y  sdf1",
"GCUCJTIYXSOXKBSNFGNFWW5MUQ54HKRPGJUTQFJ5RQXZXNOLNXYDHRAP  sdf2",
"GC2V2EFSXN6SQTWVYA5EPJPBWWIMSD2XQNKUOHGEKB535AQE2I6IXV2Z  sdf3"]


#The history store of the Stellar testnet
[HISTORY.h1]
get="curl -sf http://history.stellar.org/prd/core-testnet/core_testnet_001/{0} -o {1}"

[HISTORY.h2]
get="curl -sf http://history.stellar.org/prd/core-testnet/core_testnet_002/{0} -o {1}"

[HISTORY.h3]
get="curl -sf http://history.stellar.org/prd/core-testnet/core_testnet_003/{0} -o {1}"

Can someone help if encountered the same error . I used this same configuration on MacOs and it just worked fine .

0

It's pointless to use the KNOWN_PEERS and [HISTORY] configuration for the official common testnet, as no other node will track or serve data from your private network.

If you want to join the SDF official testnet

  • NETWORK_PASSPHRASE="Test SDF Network ; September 2015"

If you want to run your own network and it's your first node:

  • Set it to standalone mode
  • Create your own history archive (see example in standalone config, needs to be initialized with stellar-core new-hist command first)
  • Kickstart your network with the stellar-core force-scp command

If your own network is running and you want to add another node:

  • Make sure your history from above is accessable for your new node
  • Refer to the [HISTORY] that your first node writes, only the get command
  • Refer to your first (and all other existing) nodes as KNOWN_PEERS
  • I changed the NETWORK_PASSPHRASE and then tried , It is able to connect to nodes but the situation persists , that it has lost track of consensus . And new nodes are connected and dropped due to limited slots . – Minhaj Shakeel Jun 10 at 5:31
  • You have to completely start over when changing passphrase. Clear all data with stellar-core new-db – sui Jun 10 at 17:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.